Check Engine Light - Harley Davidson Street Forum - Street 500 and 750
User Tag List

 
LinkBack Thread Tools
post #1 of 6 Old 04-18-2017, 11:13 AM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Essex Junction, Vermont
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Check Engine Light

I have a recurring issue with the check engine light coming on pretty consistently. It seems to come on after being run for a while and coming to a stop, but then goes off when moving... I took it to a local H-D dealer, and they said that it was a historic code, cleared it, and didn't offer anymore detail. Has anyone else had an issue like this? Looking for some guidance, or thoughts on what to check. Thanks in advance!

Last edited by mccarthyej; 04-18-2017 at 11:16 AM.
mccarthyej is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 04-18-2017, 01:07 PM
Senior Member
 
Tucsonmax1's Avatar
 
Join Date: Aug 2015
Location: Trenton, NJ
Posts: 1,231
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
Garage
What was/is the code?? We need that info to help you

2016 Hyundai Tucson SE Coliseum Grey AWD




2018 Custom 1200
Tucsonmax1 is offline  
post #3 of 6 Old 04-18-2017, 02:20 PM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Essex Junction, Vermont
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Hey Tusconmax1. I tried getting it from them, but the service was a while ago, and they didn't document the code. I will try bringing it back to them and see if they can do their jobs this time, but was hoping someone else has seen the check engine light go on and off. I am accustomed to it coming on and staying on, but not on and off. I will see if the dealer can help out this time, but hate to have to pay them again for something they should have documented the first time.
mccarthyej is offline  
 
post #4 of 6 Old 04-18-2017, 08:21 PM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Essex Junction, Vermont
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
I had the bike checked out again today and they gave me a copy of the DTC readout. The codes were P0152 - engine running rich (rear), P0506 - idle speed control (rpm too low), and P0507 - idle speed control (rpm too high). One of the technicians said that it may be a rotor issue. Problem with that is that the warranty expired last month. Ca-ching! Any thoughts?
mccarthyej is offline  
post #5 of 6 Old 04-19-2017, 01:22 AM
Senior Member
 
Tucsonmax1's Avatar
 
Join Date: Aug 2015
Location: Trenton, NJ
Posts: 1,231
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
Garage
Hard to say. Possibly several things going on.


On a Car, I would use a Scan Tool to monitor the O2 Sensors. Rich Exhaust could be a Bad Sensor.


The Idle Speed Codes?? Both High and Low. My thought would be to check the Crankshaft Sensor. Again on a Car, I would use a DVM. Set for AC. And monitor the output of the Crank Sensor. I Diagnosed a car once with a Speedo Inop. Started with the Vehicle Speed Sensor. Had output. Checked at the Engine Computer. Had Input. There was no Output to the Speedometer. Told the Boss. He didn't believe me. Had another Tech check it. Same conclusion. Could be a Bad Crank Sensor. Or Wiring.

2016 Hyundai Tucson SE Coliseum Grey AWD




2018 Custom 1200
Tucsonmax1 is offline  
post #6 of 6 Old 05-16-2017, 04:41 PM Thread Starter
Junior Member
 
Join Date: May 2016
Location: Essex Junction, Vermont
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
(Thread Starter)
Just wanted to post a quick reply, as this issue has been resolved. The issue was a bad air intake adapter (boot). Apparently, the adapter had a hole in it, that someone, prior to me, must have rigged with a hose clamp. They clamped it so tight, that it was choking the engine of air, throwing the rear cylinder running rich code. And the idle speed control low, and the idle speed control high, was the engine trying to correct itself. The dealer covered the labor on fixing this, as it should have been remedied last August, when I brought the bike in for the same issue.

“Thanks to the Interstate Highway System, it is now possible to travel across the country from coast to coast without seeing anything.” – Charles Kuralt
mccarthyej is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
No tail light or brake light steelrain Harley-Davidson 750 Street Tech 3 06-10-2016 09:11 AM
Engine Light - Premium Fuel Alphatron Shinyskullus Harley-Davidson 750 Street Tech 5 03-02-2016 11:20 AM
Anybody get an Engine check light dogrocket Harley-Davidson 500 Street Tech 18 08-02-2015 03:23 PM
check out this Harley in Denmark Rock270 Off-topic Discussion 7 06-26-2015 06:30 PM
check engine light captainweb Harley-Davidson 750 Street Tech 1 05-19-2015 04:13 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome