Speedometer Intermittent - Harley Davidson Street Forum - Street 500 and 750
User Tag List

 4Likes
  • 2 Post By Propnut
  • 1 Post By PugslyCat01
  • 1 Post By dabomb1000
 
LinkBack Thread Tools
post #1 of 6 Old 09-05-2018, 01:19 PM Thread Starter
Junior Member
 
tsts4's Avatar
 
Join Date: Aug 2018
Location: Dumfries, VA
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage
(Thread Starter)
Speedometer Intermittent

So the speedo on my wife's new to her 2016 XG750 has become intermittent. When it cuts out it drops to zero regardless of what gear she's in when it decides to quit. Sometimes it will start working again after she comes to a stop, sometimes only after a shutdown, and sometimes not all (although at some point it has always started working again). The odometer/trip meters also stop working as well-- the display continues to function, but the meters don't register the movement and don't count up when the speedo isn't working. Any suggestions? I don't have a service manual (yet) and my motorcycle mechanical knowledge is pretty limited.
tsts4 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-05-2018, 07:32 PM
Senior Member
 
Tucsonmax1's Avatar
 
Join Date: Aug 2015
Location: Trenton, NJ
Posts: 1,231
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
Garage
Sounds to me like a Bad Speedometer. You may have to remove the Seat and Gas Tank to access the connectors. My 15 had a different Speedo unit. And take the Handle Bar off. The Dealer can program the new unit.

2016 Hyundai Tucson SE Coliseum Grey AWD




2018 Custom 1200
Tucsonmax1 is offline  
post #3 of 6 Old 09-06-2018, 07:42 AM
Senior Member
 
Propnut's Avatar
 
Join Date: Jul 2015
Location: Durban, South Africa
Posts: 459
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Garage
From your description I would first look for a loose connector.
PugslyCat01 and tsts4 like this.

2015 Street 750 Vivid Black
Propnut is offline  
 
post #4 of 6 Old 09-06-2018, 12:09 PM
Senior Member
 
Join Date: Jul 2018
Location: I split my time between rural central Iowa and rural southwest Iowa
Posts: 174
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
I've got to agree with Propnut. Try to eliminate the cheap and easy stuff before going through the hassle and expense of a whole speedometer replacement:

1) Follow the wires the best you an and check for movement at any of the connectors. See if you can tighten any of the connectors.
2) Check for corrosion in the connectors. I've known a lot of people that were resigned to getting a new battery until cleaning the battery terminals brought their car back to life.
3) Look for wires damaged along their length. If a wire is damaged internally the conductor may have a break in it. It makes contact in some positions but when the wire flexes a gap can open up. Usually the insulation will show some signs of damage at that point.
4) Resign yourself to the fact that a full speedometer replacement may be required.
tsts4 likes this.

Formerly known as "PugslyCat" until the account got locked.
2016 xg750 in Velocity Red
2007 Sportster 1200 Custom in blue and silver
PugslyCat01 is offline  
post #5 of 6 Old 09-11-2018, 10:38 AM
Member
 
dabomb1000's Avatar
 
Join Date: Apr 2017
Posts: 55
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
I had the same problem but the check engine light would come on when it happened, turned or to be a bad speed sensor at the transmission. It had a hairline crack that would allow moisture in and cause it to short out. Might be something to check
tsts4 likes this.
dabomb1000 is offline  
post #6 of 6 Old 09-11-2018, 04:51 PM
Junior Member
 
Join Date: Aug 2018
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by tsts4 View Post
So the speedo on my wife's new to her 2016 XG750 has become intermittent. When it cuts out it drops to zero regardless of what gear she's in when it decides to quit. Sometimes it will start working again after she comes to a stop, sometimes only after a shutdown, and sometimes not all (although at some point it has always started working again). The odometer/trip meters also stop working as well-- the display continues to function, but the meters don't register the movement and don't count up when the speedo isn't working. Any suggestions? I don't have a service manual (yet) and my motorcycle mechanical knowledge is pretty limited.

I had this issue on my 2018 XG500. It was still under warranty, so I took it to the shop... it turned out to be a bad speedometer.
Tinker1980 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer (odometer) error ButterSmooth Harley-Davidson 500 Street Tech 10 08-03-2017 11:23 PM
Speedometer Matt Brown Harley-Davidson 750 Street Tech 1 07-11-2016 02:58 PM
Speedometer calibration marks Obtuse Harley-Davidson Street General Discussion 2 12-02-2014 10:15 AM
Iron 883 2014 speedometer haytham Events and Meets 11 02-13-2014 08:44 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome