Odd problem xg750 - Harley Davidson Street Forum - Street 500 and 750
User Tag List

 1Likes
  • 1 Post By Botty
 
LinkBack Thread Tools
post #1 of 2 Old 07-30-2018, 10:35 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Odd problem xg750

Ever since I've owned my bike, I've had a very difficult time inflating the tires. Today I needed to bring them up to spec, but I could not get any air to go into the tires. I could check the air pressure with a gauge just fine but no air would go into them. After trying various air chucks I ended up replacing the cores of the Schrader valves and was then able to inflate the tires. I've never encountered this problem on any vehicle. The valve cores did not look damaged but would not allow air to flow in only out.
DanIII is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-31-2018, 02:45 AM
Senior Member
 
Botty's Avatar
 
Join Date: Jul 2018
Location: UK.
Posts: 229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Garage
Sounds to me like the valve needle had stuck / corroded? Glad you got it sorted but some vaseline in the inflator stem / valve might prevent this happening.

I had problems once cos I replaced the plastic dust covers with metal ones and when it came time to inflate the tyres (some months later) the caps had corroded on and I had to have the complete valves replaced - a very costly exercise and a lesson learned !
Big Rus likes this.
Botty is online now  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Leak Problem sahilspeed2002 Harley-Davidson Street General Discussion 10 12-07-2015 11:36 PM
That Lag and Leap problem OldDawg Harley-Davidson Street General Discussion 202 09-23-2015 03:20 AM
Poll Woodruff Problem, Fuel Pump Problem, No Problem bbally Harley-Davidson Street General Discussion 50 08-12-2015 07:38 AM
It's not just the fuel pump causing the surge, lag/leap problem Harlowhickalooper Harley-Davidson Street General Discussion 7 05-26-2015 11:34 AM
Problem in garage bbally Other Harley-Davidson Motorcycles 22 08-28-2014 11:08 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome