NHTSA Opens XG Investigation - Harley Davidson Street Forum - Street 500 and 750
User Tag List

 10Likes
Reply
 
LinkBack Thread Tools
post #1 of 54 Old 04-24-2015, 01:49 PM Thread Starter
Senior Member
 
HowlOnWheels's Avatar
 
Join Date: Sep 2014
Location: Denver, CO
Posts: 155
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
(Thread Starter)
NHTSA Opens XG Investigation

As of April 20th, the NHTSA looks to have opened an investigation into the "Lag and Leap" issue so many of us have been dealing with.

Details here! (You'll need to click on the "Investigations" tab)

Hope this leads to something positive for us owners.

www.youtube.com/howlonwheels
Motorcycle Film Festival
1973 CB500 Four
2015 HD Street 750
HowlOnWheels is offline  
Sponsored Links
Advertisement
 
post #2 of 54 Old 04-24-2015, 02:04 PM
Super Moderator
 
StoneFree's Avatar
 
Join Date: Mar 2014
Location: Cottonwood AZ
Posts: 1,076
Mentioned: 16 Post(s)
Tagged: 2 Thread(s)
Quoted: 390 Post(s)
Garage
Quote:
Originally Posted by HowlOnWheels View Post
As of April 20th, the NHTSA looks to have opened an investigation into the "Lag and Leap" issue so many of us have been dealing with.

Details here! (You'll need to click on the "Investigations" tab)

Hope this leads to something positive for us owners.
I would also advise any US owners that have experienced the lag and leap problem to report it to the NHTSA. They only have a very limited number of reported cases and they depend upon input from the public in determining the extent of the problem.



AYEDEE likes this.

Always remember that for every mile of highway there are two miles of ditches.
StoneFree is offline  
post #3 of 54 Old 04-24-2015, 02:13 PM
Member
 
Join Date: Jul 2014
Posts: 54
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
So glad to see this. Finally.
ride safe everyone
Street750Nc is offline  
 
post #4 of 54 Old 04-24-2015, 05:01 PM
Member
 
Join Date: Apr 2015
Posts: 85
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Garage
I noticed on there that there were 0 crashes reported. Can whoever dropped their bike report it as a crash?
ryoung048 is offline  
post #5 of 54 Old 04-24-2015, 08:45 PM
Senior Member
 
Solo750owner's Avatar
 
Join Date: Jul 2014
Location: Northern Ozaukee County
Posts: 490
Mentioned: 1 Post(s)
Tagged: 6 Thread(s)
Quoted: 145 Post(s)
Garage
Well now Harley Davidson is doing a recall on their big bikes....

Harley-Davidson recalls 46,000 US bikes over clutch fault - BBC News
Solo750owner is offline  
post #6 of 54 Old 04-25-2015, 06:36 PM
Senior Member
 
charlesskelter's Avatar
 
Join Date: Apr 2015
Location: Charlotte, NC
Posts: 367
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 122 Post(s)
Garage
I know I saw two reports that resulted in a crash when looking at their reports. They both might have been for the XG500 (one was mine). Good to see they are looking in to it.
charlesskelter is offline  
post #7 of 54 Old 04-25-2015, 09:54 PM
Senior Member
 
Join Date: Jul 2014
Location: Monterey, CA
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Garage
Love this! Thanks for the notification... and a huge thanks to everyone else that filed a claim!
ElTeeFauci is offline  
post #8 of 54 Old 04-27-2015, 12:04 PM
Member
 
Join Date: Mar 2015
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Quote:
Originally Posted by Street750Nc View Post
So glad to see this. Finally.
ride safe everyone
agreed, I think so
ahok19 is offline  
post #9 of 54 Old 04-27-2015, 01:13 PM
Junior Member
 
Join Date: Feb 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
if your'e bike lags or stalls, check to see if ur tank is venting.

there is a little rubber plug just under the gas cap. if the hole in the plug is closed, the tank won't vent, allowing pressure to build up staving the pump of gas.
cfreeze is offline  
post #10 of 54 Old 04-27-2015, 03:06 PM
Senior Member
 
Join Date: Jul 2014
Location: Monterey, CA
Posts: 170
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Garage
Quote:
Originally Posted by cfreeze View Post
if your'e bike lags or stalls, check to see if ur tank is venting.

there is a little rubber plug just under the gas cap. if the hole in the plug is closed, the tank won't vent, allowing pressure to build up staving the pump of gas.
I dont understand the logic behind this.
ElTeeFauci is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome