Newbie - hey and help! - Harley Davidson Street Forum - Street 500 and 750
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools
post #1 of 13 Old 12-17-2017, 05:56 AM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Hi all, new to the forum so hi from Melbourne Australia!

Recently bought a 2015 HD Steet 500 and already begun to do a few mods.

First off Iíve changed the seat to a Ďgunnerí single seat which sits a lot lower.
Just received my forward control kit delivered from Thailand which I saw a few guys recommended from this forum, so thanks for the advice - will be fitting these this week.
Comes with a very detailed how-to guide!

Also just received my drag bar, 7/8Ē which Iíll be swapping over soon too.

Iíve seen a thread on the tank lift mod but unfortunately the videos wonít load for me...
This is something I definitely want to do so if anyone can point me in the right direction for some info on this, that would be great!

Issue:
My rear brake is pretty squeaky which is annoying when pulling up to lights - the pads still have plenty meat left but the disc looks kinda grooved. Sure this is just wear but not sure if this can cause the squeak?
Canít seem to find any much info.
Iím going to give the pads a clean and maybe grind them slightly..

Couple of questions:
Does anyone know the minimum disc spec I can go if I were to grind it down to remove some grooves?

Second question, what the recommended oil for the 500?
I didnít get the owners handbook with the bike so Iím missing some crucial info such as this.

Thanks all, great to see so many like minded people and to have a place to source info and inspiration.

Any advice would be much appreciated.
Thanks!
Attached Images
File Type: jpg FF63DEC9-AE92-489F-A34F-14C6A365472B_1513508124450.jpg (146.9 KB, 32 views)
LWS is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 12-17-2017, 09:39 AM
Senior Member
 
Phil13's Avatar
 
Join Date: Jul 2017
Location: County Durham
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Hello Aussie,
Welcome!
For oil use a 20 -50, I'm using a fully synthetic but according to the handbook mineral 20 - 50 is OK as well.

Re your rear brake, skimming the disc may be a touch extreme at this point! Take the pads out, clean everything well, a faint smear of copper grease on the rear of the pads helps, though I believe modern mechanics are not fans of this.
Phil13 is offline  
post #3 of 13 Old 12-17-2017, 03:22 PM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Thanks for the info.

I'm originally from sunny Hull so not so far from where you are.

I'll give the pads a good clean this week and see if it resolves it.
I'll also be replacing the brake fluid when I swap over to forward controls.

Cheers
LWS is offline  
 
post #4 of 13 Old 12-17-2017, 09:12 PM
Senior Member
 
Tucsonmax1's Avatar
 
Join Date: Aug 2015
Location: Trenton, NJ
Posts: 1,231
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 205 Post(s)
Garage
You might want to change the pads to EBC FA643V. Have them on my 750. Put about 10k Miles on them. Quiet. Seem to be wearing well.

2016 Hyundai Tucson SE Coliseum Grey AWD




2018 Custom 1200
Tucsonmax1 is offline  
post #5 of 13 Old 12-18-2017, 03:25 AM
Senior Member
 
Phil13's Avatar
 
Join Date: Jul 2017
Location: County Durham
Posts: 211
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Quote:
Originally Posted by LWS View Post
Thanks for the info.

I'm originally from sunny Hull so not so far from where you are.
You swapped the sub tropical paradise of Hull for a hat with corks hanging off the brim and a didgeridoo? Utter madness
Phil13 is offline  
post #6 of 13 Old 12-18-2017, 03:31 AM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Quote:
Originally Posted by Tucsonmax1 View Post
You might want to change the pads to EBC FA643V. Have them on my 750. Put about 10k Miles on them. Quiet. Seem to be wearing well.
Thanks mate. Iím going to change over the brake fluid and give them a good buff first then if it persists, Iíll get them changed.

Cheers
LWS is offline  
post #7 of 13 Old 12-18-2017, 03:32 AM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Quote:
Originally Posted by Phil13 View Post
Quote:
Originally Posted by LWS View Post
Thanks for the info.

I'm originally from sunny Hull so not so far from where you are.
You swapped the sub tropical paradise of Hull for a hat with corks hanging off the brim and a didgeridoo? Utter madness
Haha yeh what was I thinking?
I think theyíve reached a high of -2 this week so Iím gutted to be honest!

Nothing like a scorching Christmas on the beach
LWS is offline  
post #8 of 13 Old 12-18-2017, 04:49 PM
Senior Member
 
Join Date: Feb 2017
Location: Southwest Iowa with more than a little time spent in Ames
Posts: 272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
I seem to recall there are some threads around here about issues with the 2015 bikes built in India having particularly bad brakes, specifically the pads. You might want to go ahead and change them.

Paul
Central and SW Iowa
2016 xg750
PugslyCat is offline  
post #9 of 13 Old 12-18-2017, 10:44 PM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Quote:
Originally Posted by PugslyCat View Post
I seem to recall there are some threads around here about issues with the 2015 bikes built in India having particularly bad brakes, specifically the pads. You might want to go ahead and change them.
I think I will PugslyCat, thanks for the advice.
LWS is offline  
post #10 of 13 Old 12-24-2017, 06:16 AM Thread Starter
LWS
Member
 
LWS's Avatar
 
Join Date: Dec 2017
Location: Melbourne, Australia
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
(Thread Starter)
Forward controls fitted
Attached Images
File Type: jpg 58845EE9-3F4E-414E-AFD3-6F6298B17F50_1514114114337.jpg (125.2 KB, 23 views)
PugslyCat likes this.
LWS is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey everyone! old4x4 New Members Introduction 1 09-26-2016 10:13 PM
Hey Everyone Ken Kusnir New Members Introduction 13 04-11-2016 10:13 AM
hey,, a newbie and bike virgin,, thomasjamesturner New Members Introduction 9 03-17-2016 10:06 AM
Hey everyone! Xmsteel New Members Introduction 3 07-16-2015 01:15 AM
Hey ya'll Dyna7051 New Members Introduction 14 12-27-2013 05:43 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome