Harley Davidson Street Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,244 Posts
Discussion Starter #1
Hi all. Went out in the garage this morning. Saw my Schumacher Tender/Charger (SP6) flashing. States "Bad battery" Unplugged and reconnected. Same message. This happened once before. But cleared up when I reset the charger. Guess when it warms up a bit, Have to start the Street and see what happens. I have an old battery. I could try connected it to the charger and see what happens. Its a 5-6 year old battery. Might still be good.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #3
Hard to estimate. Some winters are Mild. Dec was Mild for the most part. Then we get the fluke, 20" Snow. My work schedule, I leave at 6am. I ride past several farms. And have seen several Deer on the side of the road. So I don't ride in much in the winter. Lucky if I ride it once a week.


I do store mine with a Tender. Going to start it later today.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #5
Tested it on my old battery. Said it was charged. Hooked it back to the Street. Same issue. "Bad battery". Started right up. Ran for a few minutes. Plugged in the Tender. Now its reading Charging, 96% done. Go figure?? Schumacher must be very sensitive. Or my battery is starting to go flaky. Parts man at my dealer told me that it would be covered under the 2 year warranty.
 

·
Registered
Joined
·
504 Posts
Propnut ...........Here in SW Ontario I almost always have my bike in winter storage November 1st. Usually it stays there until April 1st. (I used to store it at a place where I couldn't get it until "after" April 15th ..........I don't keep it there anymore) That's no bike riding for 5 months!
We've been very fortunate this winter, with the mild weather, that I've been able to ride almost every month! The bike is still in storage, but now I can access it more readily. Was out riding Christmas Day, which was a first ever. Was also out in November (December) & January. So far this month I only moved it outside to "warm it up, and keep the battery charged".

FYI, right now it's a balmy -2C, and snowing
 

·
Registered
Joined
·
73 Posts
I just Jumpstarted mine. I took the seat off. I verified the stud coming out of the exhaust pipe side of the starter solenoid was positive. I very carefully clipped on to that making sure the positive jumper cable want touching anything else during the whole operation.

I touched the negative jumper cable to the large shiny round hex bolt head at the front of where the seat mounts. Cranked right up.

I made sure the caright I used to jump it was not running...
 

·
Premium Member
Joined
·
1,076 Posts
Thanks "T" as over here it is 365 days a year saddle time.

You probably have me beat although technically I could have been in the saddle every day since moving to Cottonwood AZ in June of last year. We've had snow on the ground twice but not on the roads but it was pretty cold for several days during the winter. Now we're back in the 70's (F) and it's perfect riding weather.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #10
I bought one of those Load Testers today. Solar brand digital 125A. Tested the Harley Battery. Started with 12.7V. Load Tested down to 10.3V (Automatic). Indicates OK but Weak. After the battery was on Maintain Mode. Going to call Schumacher to verify.
 
1 - 10 of 10 Posts
Top