Harley Davidson Street Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hi everyone!

My name is Pawel and I'm new - from Australia! Nice to meet you all.

I'm completely redesigning my street rod, and in the process I changed all the lights to LED. When the bike is in ignition mode it flashes at correct speed however when I start the bike, it hyperflashes. Soooo weird!

I assume canbus will sort itself out, however I'm also guessing that it would need some sort of a prod to do it first. Does anyone know the procedure to to reset canbus? I read somewhere that other harleys require the use of hazard lights which the street doesn't have...hmm

Anyway, I hope someone can help!

Here's a little snap of the ongoing project.

Edit: I posted in Street 750 forum as it's the most popular one and the guts of the bike would be 99% the same.
 

Attachments

·
Registered
Joined
·
197 Posts
So, the Street Rod comes from the factory with all LED lighting sans the headlight. Are you saying that you replaced the front and/or rear directionals with aftermarket LED's and it's messing with the CANBUS?
 

·
Super Moderator
2016 Harley-Davidson Street 750 in Sunglo Velocity Red
Joined
·
781 Posts
Another thread a couple of months ago stated that as long as you replace both the front and rear turn signals with LED ones at the same time there won't be a problem on the H-D Street series bikes.
 

·
Registered
Joined
·
197 Posts
The OP stated he has and shows a Street Rod that he installed the LED lights on. The Street ROD has all LED lights except the headlight as OEM. That's why I am wondering why he is having the hyper flash issue.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Yeah, I replaced front and rear. I'm checking wiring for issues, but seems all good there. No hyperflashing in ignition mode. The moment I start the bike it the speed increases...hmm... it may be an ECM issue, the bke has been off road since august and started seeing funny behaviours such as the transport mode stopped working etc.

I'll be taking it to HD dealer soon for a thing or two so I'll get them to scan for codes and hopefully they can fix it from the software side.
 

·
Registered
Joined
·
3 Posts
Hi everyone!

My name is Pawel and I'm new - from Australia! Nice to meet you all.

I'm completely redesigning my street rod, and in the process I changed all the lights to LED. When the bike is in ignition mode it flashes at correct speed however when I start the bike, it hyperflashes. Soooo weird!

I assume canbus will sort itself out, however I'm also guessing that it would need some sort of a prod to do it first. Does anyone know the procedure to to reset canbus? I read somewhere that other harleys require the use of hazard lights which the street doesn't have...hmm

Anyway, I hope someone can help!

Here's a little snap of the ongoing project.

Edit: I posted in Street 750 forum as it's the most popular one and the guts of the bike would be 99% the same.
I am trying to do a similar build on my Street Rod. I could use your help. DM me!
 

·
Super Moderator
2016 Harley-Davidson Street 750 in Sunglo Velocity Red
Joined
·
781 Posts
If you hover over the avatar of @PablosGuitaros you will see that he joined on January 23, 2018 and hasn't logged in since January 26, 2018. He's probably not going to see your post to a 3+ year old thread. You might try a DM to him, but don't be surprised if you get no response.
 
1 - 9 of 9 Posts
Top