Harley Davidson Street Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
My 2015 started having this problem where it will randomly lose power or stall; it’s as if it’s losing spark, like the kill switch was toggled. The engine does not fire again while coasting in gear, but after pulling the clutch it fires back up. Sometimes it sputters and needs a bit of throttle to keep running but usually is fine. When I release the clutch, it immediately dies again (as long as it’s still having its episode).

This may only happen once, or it may happen several times (at which point I’ve nearly coasted to a stop) before returning to normal. During one episode, while trying to get going, it would die once I reached 15 MPH on the dot.

The check engine light is on when it’s not firing, then goes off after a few seconds of running. Being a 2015, I can’t get codes on the odometer, and I don’t have an adapter for an OBD2 scanner.

Does anybody have any idea? I’d like to get a start on what the problem might be, since the dealership is busy and can’t take a look for another week.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
air or exhaust mods?
SE Stage 1 air cleaner kit and exhaust. ECU stage 1 download too.
I’ve had the bike like that for years and never had an issue.

But the abruptness of this issue is what makes me think it’s losing spark – it is exactly as if I toggled the kill/run switch. But the fact that it restarts when I pull the clutch (and that it once died repeatedly at 15 MPH on the dot) makes me think it’s not the kill/run switch. I’m just surprised the engine light isn’t consistently on.
 

·
Super Moderator
2016 Harley-Davidson Street 750 in Sunglo Velocity Red
Joined
·
704 Posts
I'd definitely be looking at the ignition side of things. Loose or broken wires, corroded connections, bad coil, bad switches, that type of thing.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #8 ·
Welp, the dealership found the issue, and I feel so dumb.

The battery was not the right one (the terminals were in the wrong place) so the connection wasn't good. They found unstable voltage at the ECM & BCM. They replaced the battery with the correct one and so far it has fixed it.

A few months ago, I bought that battery from O'Reily Auto. I asked for a battery and that's what they gave me. Now I want to know if I can make them pay the $377 bill :mad:
 

·
Super Moderator
2016 Harley-Davidson Street 750 in Sunglo Velocity Red
Joined
·
704 Posts
Here is a Doc Harley: After Market Batteries video you might want to watch. He starts with explaining how there can be connection problems caused by even slight issues with post alignment which is interesting. Then he goes into a spiel about why you should only use a genuine H-D battery that I take with a grain of salt.
 
1 - 9 of 9 Posts
Top