Harley Davidson Street Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Mine has been put up since mid October due to being cold. The other day it was nearly 60, so I decided to take it out for a ride. I did not start up it the whole time, but it started immediately! It was nice to be back on it! Although I drove my truck last couple days due to this lovely rain.
 

·
Registered
Joined
·
504 Posts
Did you have it plugged into a battery tender?
 

·
Registered
Joined
·
504 Posts
Where I had mine stored for the winter, I couldn't plug the Battery Tender in. (No power)
I brought mine home today as well, and plugged the Tender in right away. It's been "charging" all day now, and hasn't gone into the "maintain" mode yet! I wonder how dead it might have been ..................but I did start it up and even ride it a bit over the winter. Hmmm?
 

·
Registered
Joined
·
177 Posts
Mines in storage at the dealer. He requires a weeks notice to get it out. The best day looked like next Tue. Supposed to be mid 60's & overcast. Now its revised to rain & cold. Oh well.
 

·
Registered
Joined
·
1,244 Posts
Mine has a Weird issue with the Battery. And I keep a Schumacher SP6 on it all times (When not in use). Get done riding, Says Fully Charged and Auto Maintains. Every once in awhile it says Bad Battery, Charge Aborted. Happened a few times. But started up. The charger runs fine. When I get the money, I am getting a Lithium battery for mine. 3 Pound battery Vs. 12 or so. And has more CCA's.
 

·
Registered
Joined
·
187 Posts
mine may sit when the rainy season hits Philippines, late May thru September. rain isn't the problem, it's the flooding of the roads due to crapola infrastructure
 
1 - 7 of 7 Posts
Top