Harley Davidson Street Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,244 Posts
Discussion Starter #1
Hi all. I went to leave a parking lot, Shifted from N to 1st. And the shifter felt like it was binding. Then as I was pulling onto the roadway, It acted like there was no gears. Wouldn't shift. Engine had no power. Playing with the shifter while in traffic, It seemed to be fine after a few minutes of riding. When I got home I adjusted the Clutch Cable as it seemed to have a lot of play before engaging.
 

·
Registered
Joined
·
84 Posts
Hi all. I went to leave a parking lot, Shifted from N to 1st. And the shifter felt like it was binding. Then as I was pulling onto the roadway, It acted like there was no gears. Wouldn't shift. Engine had no power. Playing with the shifter while in traffic, It seemed to be fine after a few minutes of riding. When I got home I adjusted the Clutch Cable as it seemed to have a lot of play before engaging.
Someone must have played with ur bike in the parking lot.....
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #3 (Edited)
700 Miles, Never been done. Weird that it only had one upshift. Then stopped. Had no power. I adjusted the cable to remove some of the Free Play. When I pulled the lever back, There was about 1/4" gap. Now its about 1/8" The Shop Manual has an error. The picture shows it to be where the end is crimped onto the sleeve. That part doesn't move.


I'm going to the dealership this morning. For the Toys For Tots Run. See if it happens again. If It does, I'm leaving it with the shop.
 

·
Registered
Joined
·
766 Posts
wow!, sounds like something went haywire with the clutch.
I've seen a couple mentions somewhere about weak clutch springs in all the 2015 streets, and the newer HD 2016 streets have the newer upgraded clutch.


for HD to put upgraded clutches in their newest bikes they must know of a defect in the 2015 models.....will this be the next recall?
maybe we could start a new thread asking anyone here if they have had their clutch replaced under warranty.


I'd like to know more about this, I don't want to get stranded out riding someday.....:(
 

·
Registered
Joined
·
4 Posts
I have a somewhat similar problem. My bike has just been replaced with the new Fuel Pump Recall Part and I never had the problem before the recall. Seems like my stock fuel pump was better than the recall. I park my Street 500 on a slightly sloped platform, not a relatively flat surface with the front wheel facing upwards. Before I kill the engine, I always leave it on 1st gear and then use the kill switch to stop the bike and then lock the handlebars and take the key out. I have noticed loss of power every time I come home from work. The bike starts perfectly fine and after a couple of minutes, after shifting to 1stgear and try to throttle away, the engine seems to lose power and die unless throttle more. It feels like there's a blockage or clogging??? I am going to the dealership tomorrow.

Any thoughts everyone or similar problem?
 

·
Registered
Joined
·
766 Posts
I also seen a post here a while back, where they found that a bad ground wire causing a problem like yall are saying
as far as losing power.


my engine just shut off for no reason once while riding, hasn't happened again, but now I'm kinda skiddish about when and where it will happen again and exactly what caused it to just shut off.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #9
Sunday I went with the Bucks County HOG Chapter to an ABATE: Toys For Tots run. Held in Philadelphia PA. Seemed to be running fine


That's me on the right. In the Yellow and Black jacket.
 

Attachments

·
Registered
Joined
·
766 Posts
Mine Seemed to be running fine after I adjusted the Clutch cable

did you notice if the adjuster had been tampered with?
if not, it may still be an internal problem.
can you tell if the clutch acts differently?
does it seem to slip any on hard acceleration?
 

·
Registered
Joined
·
766 Posts
Sunday I went with the Bucks County HOG Chapter to an ABATE: Toys For Tots run. Held in Philadelphia PA. Seemed to be running fine


That's me on the right. In the Yellow and Black jacket.

good that it's running fine....
now that's a cute lady standing beside you :) with her palms up
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #12
I don't know who she is. There was another Street 750 there. A 2016 Vivid Black. But I don't see her in the picture. The GM of Brian's is to the right of the R on the trailer.


Clutch Slippage? Didn't notice any. I don't Full Throttle it. Feels like it wants to throw me off if I hit it to hard.


I thought it was a little loose to begin with.
 
1 - 12 of 12 Posts
Top