Harley Davidson Street Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
My bike not starting after replacing throttle cable, please let me know what I need to check?
For changing my cable I had to loosen up the tank to get access,
here is the instrument cluster
27972
 

·
Registered
Joined
·
55 Posts
Good Morning...
The display on your speedometer is like this when you turn the ignition key to start?
Did you check that all the backups are ok?
Are all the plug connections where they belong (plus and minus)?
There where the brake fluid is, behind it are some fuses and relays.
Greetings enRico
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
@Janmad for changing the throttle cable I did some modifications for that I unplugged a connector and connected properly but the system didn't recognise it I think after I disconnected the battery and connected this issue solved, but my bike didn't start after that I check the battery voltage using a multimeter show 12.4 now I put it on charge.
 

·
Administrator
"Loose Nut" from Houston, Texas
Joined
·
447 Posts
Sounds like low or bad battery. Have the battery tested. Might show 12.4 with no load, but when load (starter) is on it drops to low.
 

·
Administrator
"Loose Nut" from Houston, Texas
Joined
·
447 Posts
I hear it cranking it that video. Did you confirm the injector wires didn't get unplugged when you replaced cable. I've done things like that before. I suggest to double check all connections in the area you were working.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 · (Edited)
@Lesblank i removed this plug and connected again it started once today after 2minutes it automatically off with that tick tick sound. anything I need to check ? can you tell me where the tick tick sound comes and why? do I need to check the fuel pump ?
27978
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
@Lesblank i checked the connectors all connected, I only disconnected the throttle sensor and I connected, where the tick tick sound comes from? do I need to check the fuel pump or something?
 

·
Administrator
"Loose Nut" from Houston, Texas
Joined
·
447 Posts
Not sure which relay that is. Normally a relay will click when it doesn't have full power. Hopefully someone will chime in to which relay that is.
 

·
Registered
Joined
·
29 Posts
The videos have been taken down by the user on YouTube.
I just had my fuel tank off. There are two electric connections. One, is a multi-wire plug, that connects to the fuel pump plate. Two, there is a ground wire that bolts to a chassis ground under the seat.
Also, the fuel line has to be properly seated into the fuel connector under the fuel pump plate. This connector is silver and it is the 'female'. The 'male' is the short fuel line that attaches to the right, to the throttle body. If this connector is not properly seated you will be getting no gas.
Since the videos are gone, is the starter cranking?
 
1 - 14 of 14 Posts
Top