Harley Davidson Street Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello, new member with 2015 Street 500. Bike was a Christmas gift from my sons. Bike came with K & N High Flow replacement filter and Speed Merchant slip on muffler. After checking back plug, could tell running very lean. Put stock muffler back on but left K & N filter, still not running very well. Son's were telling me that I need a tuner. Need Help? Last night one of my son's started doing some work on bike. Disconnected ECM wiring plugs under seat and plugged them back in without informing me that he was doing it. Now the bike will not start, was starting fine before. Anybody have any idea what is wrong? Thanks, Daryl
 

·
Registered
Joined
·
182 Posts
Hello, you need a tuner if you change the airflow and muffler. The bike is electronically tuned for original settings. Once you alter that, it wont run peak performance. I have a K&N air intake and V&H performance exhaust then linked it all together with the V&H tuner. Sorry but there is no other way for doing this accurately. Good luck and welcome to this forum. Ride safe!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks Edgar for responding. I thought that was the case with tuner. The reason it would not start was that the Bank Sensor had gotten moved under the seat. This is the first time I have encountered a Bank Sensor.
 

·
Super Moderator
Joined
·
361 Posts
Any time that you have changed to a free flow intake and the exhaust you will throw off the air to fuel mixture. The tuner updates the ECM to enrich the mixture.

I don't know if all bikes come with a tip (bank) sensor or if H-D put it on these since the model was aimed at new riders and for the H-D rider academy. I know my 2007 Sportster has one, but didn't recall it from the few times my Street 750 has been down.
 
1 - 4 of 4 Posts
Top