Harley Davidson Street Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,244 Posts
Discussion Starter #1
Hi all. Replaced my Ignition Coil with an Accel. Listed as fitting the Sportster (XL) models. The XG's both use the Same as the XL. While in there I found the plastic locking cap wasn't fully on. The side where the wires insert into the connector. Accel #140412


Drag Specialties also has a model. Cheaper. Probably an OEM replacement.
 

·
Registered
Joined
·
8 Posts
Hi Tucsonmax1,
I am new around here, new to HD as well. I would like to know a couple of things:
Have you replaced the spark plugs and the wires as well?
Does the new coil work better than the original in terms of smoothness, fast start, better fuel mileage?
Thank you.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #3
Hello. Yes I did change the wires. That was the First thing I changed. And Weird thing is, Since I put the Sumax 8mm wires on, Has not had the Start/Stall problem. Did the coil. Haven't done the plugs yet. I did check the rear cylinder yesterday. Front one look like you need to remove the gas tank. And with strong T-Storm warnings posted, I didn't want to get caught in the rain.


The Rear Plug? It had white powder on it. Not sure if the ceramic was cracking? I saw something weird looking on it. A couple of lines.


My MPG's are around 51-52. Average. Sometime have been able to get 58. I also have a Fire Brand Grand Prix muffler and K&N AF. Using a V&H FP3. Thing moves when I want it to.
 

·
Registered
Joined
·
60 Posts
Front one look like you need to remove the gas tank.
I removed the tank bolt under the seat and slightly lifted the tank up. My socket wrench had plenty of room to remove the front plug. I didn't have to disconnect any lines. Try it when you get some time.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #5
Has anyone used NGK plugs?? I have used their Iridium in previous bikes. Without problem. Those were Japanese units.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #6
Changed the plugs today. Installed the NGK Iridium CR9EIX. Its raining. Haven't had a chance to test them.
 

·
Registered
Joined
·
8 Posts
Sorry for the delay, apparently this forum does not show whether there is a reply or not. I have used ngk iridium on all my vehicles for the past 10 years or so. On my previous bikes I had mixed results: on my old Magna, they lasted as long as the bike. On my Marauder they lasted very little. I guess it depends on the bike. I am afraid to replace anything with non-Harley parts due to the warranty.
Currently, my 750 burns a tremendous amount of oil and the dealer is investigating the issue. 1600 miles and severe oil burning with lots of smoke is not quite what I was expecting from a brand new vehicle that was pampered and used very gently...
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #8
The Oil Burning? Might be caused by Bad Rings. Or Valve Seals. Depends How bad it is?? Smokes when started, Then goes away is Usually Seals. Smoking on Acceleration is Usually Rings.


Personally, I think HD Quality Control sucks. Not sure IF I would buy another. But the Honda 750 is too heavy for me. Yamaha I need to move up to a VTX1300 to get water cooling. Kawasaki Vulcan 600, I need Mid controls.
 

·
Registered
Joined
·
8 Posts
...another late reply...
The bike was in the shop exactly one month. Apparently it was missing about 1-1 1/2 inches from an oil ring. I can only assume it was installed that way since the technician could not find the missing part anywhere. Harley did the right thing, fixed it properly at no cost. I now have over 2000 miles since the repair and after the 1000 mile oil change it did not seem to burn any oil. I am very satisfied with the repair and with the bike in general. I have done the stage 1 complete SE, changed the spark plug wires with SE as well, my gas mileage is usually over 45/gal. It used to be about 42 before everything happened. I am considering changing the ignition coil and looking for a seat, probably Corbin. The original seat is not really butt-friendly.

I find this forum a little hard to use due to the fact that I don't get any notification of a reply. However, I will check once in a while.

Thank you for your reply.
 
1 - 10 of 10 Posts
Top