Harley Davidson Street Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
So the speedo on my wife's new to her 2016 XG750 has become intermittent. When it cuts out it drops to zero regardless of what gear she's in when it decides to quit. Sometimes it will start working again after she comes to a stop, sometimes only after a shutdown, and sometimes not all (although at some point it has always started working again). The odometer/trip meters also stop working as well-- the display continues to function, but the meters don't register the movement and don't count up when the speedo isn't working. Any suggestions? I don't have a service manual (yet) and my motorcycle mechanical knowledge is pretty limited.
 

·
Registered
Joined
·
1,244 Posts
Sounds to me like a Bad Speedometer. You may have to remove the Seat and Gas Tank to access the connectors. My 15 had a different Speedo unit. And take the Handle Bar off. The Dealer can program the new unit.
 

·
Registered
Joined
·
174 Posts
I've got to agree with Propnut. Try to eliminate the cheap and easy stuff before going through the hassle and expense of a whole speedometer replacement:

1) Follow the wires the best you an and check for movement at any of the connectors. See if you can tighten any of the connectors.
2) Check for corrosion in the connectors. I've known a lot of people that were resigned to getting a new battery until cleaning the battery terminals brought their car back to life.
3) Look for wires damaged along their length. If a wire is damaged internally the conductor may have a break in it. It makes contact in some positions but when the wire flexes a gap can open up. Usually the insulation will show some signs of damage at that point.
4) Resign yourself to the fact that a full speedometer replacement may be required.
 

·
Registered
Joined
·
55 Posts
I had the same problem but the check engine light would come on when it happened, turned or to be a bad speed sensor at the transmission. It had a hairline crack that would allow moisture in and cause it to short out. Might be something to check
 

·
Registered
Joined
·
10 Posts
So the speedo on my wife's new to her 2016 XG750 has become intermittent. When it cuts out it drops to zero regardless of what gear she's in when it decides to quit. Sometimes it will start working again after she comes to a stop, sometimes only after a shutdown, and sometimes not all (although at some point it has always started working again). The odometer/trip meters also stop working as well-- the display continues to function, but the meters don't register the movement and don't count up when the speedo isn't working. Any suggestions? I don't have a service manual (yet) and my motorcycle mechanical knowledge is pretty limited.

I had this issue on my 2018 XG500. It was still under warranty, so I took it to the shop... it turned out to be a bad speedometer.
 
1 - 6 of 6 Posts
Top