Harley Davidson Street Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,
So I just bought my first Harley which is a 2015 Street 500. Unfortunately, I get it home and drive it for the first time and it bogs down and doesn’t have much power when driving. It sounds like the engine is missing. However, when I rev the engine and am not driving the bike it is much better. Any insight that you guys can provide would be greatly appreciated!
Thanks,
 

·
Registered
Joined
·
13 Posts
Have you checked to see if spark plug wires are completely seated on the plugs? I had same/similar issue in the spring. I checked the wires and 1 was not seated all the way on the plug. My problem was resolved after pushing wire back on the plug. Don't know how it got that way in first place just glad it was an easy fix. ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the idea but unfortunately I just checked them and they are OK. This is really frustrating.
 

·
Registered
Joined
·
265 Posts
You say 'bogged down' - what type of performance is lacking i.e. acceleration, top speed etc.

What is the mileage?

Has the bike been altered from stock? i.e. has it had a different exhaust or air filter fitted?

Has it been serviced recently? Is the air filter clean?

Do you know if it has been re-tuned?



May just need a little fettling ;)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hey Botty,
Good questions. The bike doesn’t accelerate. However, when I put it in neutral and rev the engine it revs, but it sounds to me like it isn’t taking the gas. The bike hasn’t been modified and I just brought it home from the Harley Dealer where they said they checked everything. However, if you ride the bike for 2 minutes you will experience the issues that I am describing.
Thanks,
 

·
Registered
Joined
·
265 Posts
You say your bike is a 2015 500cc. Are you able to say how the bike has been treated by the previous owner(s)?

Hate to say this but in 4 years inconsiderate owners can do some damage to a motorbike that affects its performance.
Having said that the fact that it will rev is good news.
Assuming your bike has been serviced regularily and plugs and valves are ok and set correctly - which if HD have had it to check I again assume they would have checked these area's as it would be what I would look to first? Also there are no 'bent / trapped' fuel delivery pipes or debris in the tank / fuel lines. This strongly points to a fuel / air / ignition problem. You could briefly try running it without the air filter and see if there is an improvement - if there is do not run it like that as over time engine damage could result. Look instead to give yours a thorough clean or get a high performance air filter.
If there is no improvement then likely your bike would benefit from a re-tune. Not sure how many garages near you are equiped to do this - your HD dealer certainly could at a price. If you are considering keeping your bike for a time it may well be worth purchasing a tuner. I opted for an FP3 as I did a little research and this suited my purpose but there are many other tuners (cheaper too) that can do a similar thing.


I could wrongly assume here that you purchased the bike from the same shop that you took it to in order to have it checked out for poor running - if so it is in their interest to not find a problem and perhaps taking it to somewhere else if you do not have the knowledge to diagnose the problem may point you in the right direction?



Very likely this issue is a very minor problem but as with all problems of this nature you have to go back to basics and consider all that it could be, then one by one check them and rule them out before going to the next and obviously sooner or later you will find the culprit!


Good luck.
 
1 - 6 of 6 Posts
Top