Harley Davidson Street Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Does anyone know what the fluid inside the voltage regulator is? I thought it was dielectric grease but after touching it, it feels like gear lube. Most of the fluid is on my garage floor now but I want to replace it before I put everything back together.
 

·
Registered
Joined
·
48 Posts
I'm not sure if you are joking, or serious. the Voltage Regulator is a sealed unit. if it is leaking, the entire regulator has cracked and needs replacing. there is no refilling it. Be sure its not the oil filter leaking or on an ABS equipped bike its not leaking fluid from the pressure diaphragm.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I am serious. When I disconnected the large gray connector it had an oily fluid inside. The black connector did not. My first assumption was oil since the voltage regulator is right next to the oil filter but I did not see any evidence of a leak.
 

·
Registered
Joined
·
211 Posts
As Inky says, there is no fluid in a voltage regulator. If your Street has no leak from the oil filter, and no leak from the ABS module if fitted, and is charging ok, then you would have to assume at some time there has been a spillage. Has your bike had an oil change at some time? Maybe a small spillage when removing the oil filter or something along those lines.

If the regulator is not damaged, there is no oil leak, no brake fluid leak and it's charging ok, I would just clean up the connector and motor on.
 

·
Registered
Joined
·
5 Posts
I am serious. When I disconnected the large gray connector it had an oily fluid inside. The black connector did not. My first assumption was oil since the voltage regulator is right next to the oil filter but I did not see any evidence of a leak.
I know its an old thread...still..
.
No seriously i had a bad regulator...while changing it i noticed that... .the same thing happened ..i have no idea how that's happening..


It looks like motor oil is coming through the wire..i am certain...because i thkrougly cleaned everything..
But is this a normal thing?

Any updates on ur condition
 

·
Registered
Joined
·
49 Posts
I had the same problem, oil leaked and followed the line to regulator. Check your gasket and loose screw from valve cover down to engine side cover. Use duct tape to cover the connector or silicon to seal it.
 
1 - 6 of 6 Posts
Top